Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7435 closed bug (invalid)

Firefox title attribute (tooltips) stop working when returning False from a bound 'mouseout' event.

Reported by: phun007@… Owned by:
Priority: low Milestone: 1.5
Component: event Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Please refer to http://jsfiddle.net/QHuxh/ for an example demonstrating the behavior. If you bind a 'mouseout' event to an element with child elements (a table or div with child divs) and return False in that event handler, the tooltips (values in the title attribute of the element) stop showing in Firefox after the first mouseout event is triggered. In the example above, if you hover over Row 1 and then go to Row 2, the tooltip doesn't show for an further hovering of the Rows. The tooltips will start working again if you hover outside of the parent div and then hover over any part of the parent div (but only for one time, then they stop again).

I tried to come up with an example that was as simple as possible to reproduce the problem. If we return True out of the mouseout event handler, everything works as expected. I've boiled down the problem to either jQuery or Firefox itself.

Also note that this is limited to Firefox. Chrome, Safari and IE work as expected, even when returning False. This behavior is present is all versions of jQuery as well.

Change History (7)

comment:1 Changed 9 years ago by Rick Waldron

By "tooltip" are you referring to the browser's native alt/title tag display?

comment:2 Changed 9 years ago by boushley

Ya, I believe he is referring to the native tooltip, and he's only talking about returning false from within the mouseout event handler, so I really think this is a firefox bug not a jQuery bug.

comment:3 Changed 9 years ago by Rick Waldron

Component: unfiledevent
Priority: undecidedlow
Resolution: invalid
Status: newclosed

It's not a bug at all, it just takes a few seconds to appear.

comment:4 Changed 9 years ago by snover

The original testcase has invalid HTML and is invalid. If the HTML is well-formed, this issue does not occur. Furthermore, if you are displaying tabular data, you should not be using non-semantic div and span tags to display it. valid test case what the code should look like

comment:5 Changed 9 years ago by phun007@…

I'm sorry, in my attempt to get the problem to display itself in its simplest form, the meaning behind the example got lost and thus you were not able to interpret the reason for the code example. I create a new test case which still shows that after 2 or more mouseout events the browser stops showing the tooltips (the element's title attribute in a pop-up).

http://jsfiddle.net/p2D2V/1/

The basic gist of the code is to apply a CSS class on the row under the mouse on a table. I ran into this issue when using one of the jQuery grid plugins, but was able to reproduce the problem without any of the plug-in's code, which makes me believe it is either a jQuery bug or Firefox bug.

Using the updated example, can someone prove/disprove that this is an issue with jQuery's handling of the mouseout event in Firefox? Thanks!

comment:6 in reply to:  3 Changed 9 years ago by phun007@…

Replying to rwaldron:

It's not a bug at all, it just takes a few seconds to appear.

You're conclusion is false. The tooltips appear right away but then never re-appear until you move the mouse out of the table region. Refer to the latest example I posted: http://jsfiddle.net/p2D2V/1/.

comment:7 Changed 9 years ago by snover

Whatever you’re experiencing here, it isn’t a bug in jQuery, and it’s not something we would be able to solve anyway since there is no “prevent the default action but don’t prevent the browser from doing what it normally does when it prevents the default action”.

Note: See TracTickets for help on using tickets.