Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7429 closed bug (invalid)

$('#myId') returns an array

Reported by: the.garbage.demon@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: jqueries Cc:
Blocked by: Blocking:

Description

$('#myId') returns an array. It's totally illogical. I'm asking for a unique element !

I though Jquery was a good choice...but if even the more basic element of the selector system of Jquery makes no senses at all...i'll change.

Change History (2)

comment:1 Changed 9 years ago by snover

Resolution: invalid
Status: newclosed

Thanks for the report, but this is not a bug. jQuery functions return jQuery objects. Please read the API and general documentation. In the future, use the jQuery Forum for support requests. Also, in general, if you want to get any sort of assistance at all from a project, threatening to use something else is not likely to win you any friends—and nobody really cares.

Last edited 9 years ago by snover (previous) (diff)

comment:2 Changed 8 years ago by dmethvin

Keywords: jqueries added
Note: See TracTickets for help on using tickets.