Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#7426 closed bug (duplicate)

Conflict with Prototype.js caused by early exposure of global variables

Reported by: arrix Owned by:
Priority: undecided Milestone: 1.5
Component: selector Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Open http://prototypejs.org/ in google chrome, copy and paste content from http://code.jquery.com/jquery-1.4.3.js to the javascript console and run it. An error is thrown: Error: NOT_SUPPORTED_ERR: DOM Exception 9

The error is thrown by a call to div.getElementsByClassName("e") in sizzle.js. HTMLElement.prototype.getElementsByClassName is overwritten by prototype.js and it uses $ which is overwritten by jQuery. The result is that jQuery can't finish initializing and prototype is also left broken.

window.$ and window.jQuery is exposed at the end of core.js before the feature detection code in sizzle.js.

// Expose jQuery to the global object
return (window.jQuery = window.$ = jQuery);

If I move the exposure code to the end of outro.js and call jQuery.noConflict(true) right after the jQuery code, then both prototype and jQuery will be fine.

I know why the exposure is advanced to core.js but maybe there is a better way to avoid the conflict. e.g. Put sizzle.js code to the beginning because it doesn't rely on jQuery anyway.

The discussion about this issue in the dev forum: https://forum.jquery.com/topic/jquery-conflicts-with-prototype-and-the-fix

Change History (2)

comment:1 Changed 7 years ago by Rick Waldron

Component: unfiledselector
Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Rick Waldron

Duplicate of #4365.

Note: See TracTickets for help on using tickets.