Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7415 closed bug (worksforme)

ajax event success and complete are not fired in version 1.4.3

Reported by: ma083@… Owned by: ma083@…
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Problem after upgrade from version 1.4.2 to 1.4.3

I upgraded from 1.4.2 to 1.4.3 because the version 1.4.2 makes javascript to break in IE7 and IE8. After upgrading all the IE errors dissapeared and were no javascript errors in any browser. But the ajax calls doesn't work anymore the events complete and success.

The events complete and success(when there are inside of the $.ajax) are not fired anymore in any browser.

If I change back to jquery version 1.4.2 the events are fired again.

Change History (7)

comment:1 Changed 9 years ago by anonymous

I want to correct what I wrote in the title. Are not fired in version 1.4.3 not in 1.4.1

I didn't tested in 1.4.1. But all I know that events worked fine in 1.4.2 but are not working anymore after upgrading to 1.4.3

comment:2 Changed 9 years ago by addyosmani

Owner: set to ma083@…
Status: newpending

Please supply a reduced test case that reproduces this issue, ideally on jsFiddle.

comment:3 Changed 9 years ago by addyosmani

Summary: ajax event success and complete are not fired in version 1.4.1ajax event success and complete are not fired in version 1.4.3

comment:4 Changed 9 years ago by addyosmani

#7414 is a duplicate of this ticket.

comment:5 in reply to:  description Changed 9 years ago by anonymous

try to use jquery 1.4.4rc2,jquery 1.4.4rc1 or 1.3.2(i recommend 1.3.2)

i had the same problem with 1.4.3,i used in version 1.4.3 the callback function $(element).load(url,settings)

comment:6 Changed 9 years ago by anonymous

The bug can be closed. I solved the problem. There are a lot of modifications between 1.4.2 and 1.4.3 that might affect the script. The events were not fired as there were some errors in the script. The only mistery is how the previous versions of jquery was more tolerant with the errors and the events were fired normally, and why the ie error console did't signaled any error and just didn't fired the events and instead confirmed that the script ran without errors.

comment:7 Changed 9 years ago by Rick Waldron

Resolution: worksforme
Status: pendingclosed

Per request of reporter

Note: See TracTickets for help on using tickets.