Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#7410 closed bug (duplicate)

cannot change input value in a variable

Reported by: anonymous Owned by:
Priority: low Milestone:
Component: attributes Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a variable: var jObj;

Trying to change value with: $('input[name=something]', jObj).val('12345'); I can read back the right value: alert( $('[name=retry]', jObj).val() );

BUT alert( $('<p />').append(jObj).html() ) shows <input name="something" value="" />

Note: I can modify all attriubte of input except value!!

Change History (4)

comment:1 Changed 9 years ago by boushley

I've created a jsFiddle to show this test case http://jsfiddle.net/boushley/KWBQB/ There is some interesting behavior happening with manipulating the value in memory vs what happens when it's added to the dom or another element.

comment:2 Changed 9 years ago by Rick Waldron

Component: unfiledattributes
Priority: undecidedlow
Status: newopen

comment:3 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: openclosed

comment:4 Changed 8 years ago by Rick Waldron

Duplicate of #1536.

Note: See TracTickets for help on using tickets.