Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7390 closed bug (invalid)

Chrome7: window.open blocked on synchronous ajax call

Reported by: vincedev Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4
Keywords: Cc:
Blocked by: Blocking:

Description

I've noticed a bug appeared in jquery-1.4.js

Basicly, chrome always block popup "opened" in (synchronous) ajax success function. I guess it's due to this commit: https://github.com/jquery/jquery/commit/fe6c86d53046b0f4d648f61c0b8e75387af65152

Test url: http://jsfiddle.net/A6JMb/ (on 1.4.3)

Note: 1.3.2 version works fine.

Change History (3)

comment:1 Changed 9 years ago by vincedev

Additionnal infos:

It seems to be a chrome bug, i made a "native" js test: http://jsfiddle.net/ymFL3/4/

syn ans asyn calls block popup

comment:2 Changed 9 years ago by snover

Resolution: invalid
Status: newclosed

Thanks for the report, but this is not a bug in either product. Putting window.open inside an asynchronously executed function causes it to lose the initial call stack, which means the browser does not know if it occurred from a user-generated action or not, which means it blocks any attempts to pop up windows. This will happen regardless of if it is inside an interval or if it is inside onreadystatechange.

comment:3 Changed 9 years ago by vincedev

Yes, i'm aware of that, but the Chrome bug i described is about synchronous ajax calls.

Note: See TracTickets for help on using tickets.