Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7388 closed bug (invalid)

hoverintent + superfish no more working with 1.4.3 & 1.4.4 rc

Reported by: jquery@… Owned by: jquery@…
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

works ok with jquery 1.4.2 (and lower)

when using jquery 1.4.3 , the menu disapears immediatly when leaving it, instead of remaining open a few seconds.

Change History (8)

comment:1 Changed 9 years ago by snover

Owner: set to jquery@…
Status: newpending

Please provide a working test case demonstrating this issue.

comment:2 Changed 9 years ago by Pascal KISSIAN <jquery@…>

http://jsfiddle.net/LzcBf/1/

when changing to jquery 1.4.3 the menu disapears immediatly when leaving it..

comment:3 Changed 9 years ago by jitter

Thanks for the test case, but next time please read how to report bugs where multiple times is mentioned that you should reduce, reduce, reduce your code to the bare minimum which reproduces your problem. Instead of posting a big blob of html which has css and 2 jQuery plugins mixed in.

Initially I just wanted to trim your test case down a little to make it readable/graspable but while doing that (reduce, reduce, reduce) I also found the cause of your problem (but actually you could have discovered this on your own). Just remove this anyway unneeded css-rule

ul#yak_css_menu_1 li:hover>ul{display:block;}

and your sample works fine for me in jQuery 1.4.3 too.

btw this is what a trimmed down test case could look like (actually it could be even smaller but whatever)

comment:4 Changed 9 years ago by jquery@…

Status: pendingnew

thanks for your quick answer, but the line:

#menu li:hover > ul { display: block; } is needed to have a menu behaviour when javascript is disabled...

you can test it here:(commented javascript) http://jsfiddle.net/LzcBf/6/

when javascript is disabled within the browser,it falls through gracefully with the css menu (of course without javascript enhancements)

It works ok with jquery 1.4.2 (or lower) but the functionnality is broken with jquery 1.4.3 ....

thanks for looking at it further...

comment:5 Changed 9 years ago by SlexAxton

Status: newpending

At this point, we have to consider this an issue with superfish, not with jQuery. If you can reduce the problem down to something in jQuery we'd be happy to help.

comment:6 Changed 9 years ago by jitter

In the meantime until you can confirm this to be a bug in jQuery you can use this "workaround" (actually it isn't really a workaround).

test case: With this version the menu still works without javascript. To test it you need to really disable javascript support in your browser when visiting the test. (i left the superfish commented out so, when commented in the menu works with and without javascript)

Version 0, edited 9 years ago by jitter (next)

comment:7 Changed 9 years ago by Pascal KISSIAN <jquery@…>

I find out another workaround without using the noscript tag... (adding a new class an removing it with jquery)... http://jsfiddle.net/LzcBf/9/ I prefer using it this way for the cms I am writing...

I am not able to confirm if it is a jquery bug...

the only thing I am sure is that it worked with jquery 1.4.2 and no more with jquery 1.4.3...

The person who has coded superfish didn't provide any e-mail address nor a specific forum or bug tracking system... so I am not able to submit him that issue...

thank you for your interest... If I am the only person who is concerned by this issue, I can just go with my workaround...

best regards, Pascal

comment:8 Changed 9 years ago by addyosmani

Resolution: invalid
Status: pendingclosed

As this is an issue which appears to mainly be caused by an outdated plugin and it doesn't appear that the original plugin author nor the original ticket submitter will be able to reduce the test-case of what is wrong with the plugin down beyond what Jitter has already achieved, I am closing this as invalid. We have supplied workarounds (and the submitter themselves have one). If its the case that further investigation is required please re-open.

Note: See TracTickets for help on using tickets.