Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7384 closed bug (duplicate)

Error with IE7 and jQuery 1.4.3 only

Reported by: koD Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Hello everyone.

I have found a bug who occurs with the jQuery 1.4.3 version with IE7 (and probably next version but I don't know!) This error cannot be reproduced with the jQuery 1.4.2!

So look my example.

the index.html page:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
	<head>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
		<title>test page</title>
		<!--<script type="text/javascript" src="jquery-1.4.2.js"></script>-->		
		<script type="text/javascript" src="jquery-1.4.3.js"></script>
		<script type="text/javascript" src="jquery.customForm.js"></script>
	</head>
	<body>
		<div class="container">
			<script type="text/javascript">
				$(document).ready(function() {
					$('#submitLink').click(function() {
						$('.mainForm').submit();
					});
					
					$('.mainForm').customForm({
						validation	:	{	'gameId' : {
												'minimum' : {
													'message' : "Veuillez sélectionner un jeu.",
													'minimum' : 1
												}
											},
											'ip' : {
												'notEmpty' 	: {
													'message' : "Veuillez saisir une adresse IP."
												},
												'regex'	: {
													'message' : "Veuillez saisir une adresse IP valide.",
													'pattern' : '^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(:[1-9]{1}[0-9]*)*$'
												}
											}
										},
						errorTitle	: "Impossible de contacter le serveur!",
						errorText	: "La page demandée n'a pas pu être contactée, le serveur est-il down? "	
					});

				});
			</script>	
			<div class="content" class="span-24 last">
				<form id="server" class="mainForm" action="#" method="post">
					<input id="id" name="id" type="hidden" value="1"/>
					<div class="inputHolder">						
						<label for="gameId">Game</label>
						<select id="gameId" name="game.id">
							<option value="-1">-> Select an option</option>
							<option value="1" selected="selected">Counter Strike 1.6</option><option value="2">Counter Strike Source</option><option value="3">Trackmania 3</option>
						</select>
					</div>
					<div class="inputHolder">
						
						<label for="ip">IP address</label>
						<input id="ip" name="ip" type="text"/>
					</div>
					<div class="buttonHolder">	
						<a href="#" id="submitLink" class="button centered">
							<span class="modify">Modify</span>
						</a>
					</div>
				</form>

			</div>
		</div>
</body>
</html>

The jquery.customForm.js script:

jQuery.fn.customForm = function(settings) {
  settings = jQuery.extend({
	  errorMessage  		:	'errorMessage',
	  inputHolder   		:	'inputHolder',
	  buttonHolder			:	'buttonHolder',
	  focusedClass  		:	'focused',
	  errorClass			:	'error',
	  keyElementsValidated	:	'keyElementsValidated',
	  validation			:	{},
	  errorTitle			:	'',
	  errorText				:	'',
	  errorImage			:	'/images/icons/error.png'
  }, settings);
  
  var possibleValidationRules = ['notEmpty', 'isUnique', 'minimum', 'regex'];

  
/**
	plugin
*/
  return this.each(function() {
    var myForm = $(this);
	
    // Select form inputHolder and attach them highlighter functionality
    myForm.find('.inputHolder').each(function() {
		alert('what?');
    });
	myForm.find('.' + settings.inputHolder + ':first').css("border-top", "none");
	
	// Select form buttonHolder and attach them highlighter functionality
	myForm.find('.' + settings.buttonHolder).each(function() {
		alert('what?');
    });

  });
};

I hope this can help you!

Change History (5)

comment:1 in reply to:  description Changed 9 years ago by jitter

Replying to koD:

I have found a bug who occurs with the jQuery 1.4.3 version with IE7 (and probably next version but I don't know!) This error cannot be reproduced with the jQuery 1.4.2!

So look my example.

...

I hope this can help you!

Umm, you forgot to tell what the actual bug is??

Please take a look at How to report bugs for jQuery. Then provide a reduced test case on http://jsfiddle.net and please include a description what bug you experience exactly

comment:2 Changed 9 years ago by koD

It's the error "Object doesn't support this property or method" in line 3904 of the not compressed jQuery 1.4.3 source.

comment:3 in reply to:  2 Changed 9 years ago by koD

And sorry but I don't find where I can edit my first message to add the url to jsFiddle.

http://jsfiddle.net/Amz7b/

comment:4 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

In the future, please follow the How to Report Bugs guidelines.

comment:5 Changed 9 years ago by snover

Duplicate of #7212.

Note: See TracTickets for help on using tickets.