Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#7381 closed bug (worksforme)

.live binding of form submit event does not work in IE versions < 9

Reported by: Paul Payne <paul@…> Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

The following code produces a form with a jQuery live binding on the submit. In most browsers, this results in the alert "Submit event triggered" and the form should not be submitted. However, in Internet Explorer versions less than 9(beta), the form's live binding on the submit event is not triggered and the form submits to "fail.html".

This happens on all versions of jQuery.

<!DOCTYPE html>
<html>
<head>
  <title>jQuery Form Submit Test</title>
  <script type="text/javascript" src="http://code.jquery.com/jquery-1.4.3.min.js"></script>
  <script type="text/javascript">
    $( function() {
      $('form').live('submit', function(e){
        alert('Submit event triggered');
        e.preventDefault();
      });
    });
  </script>
</head>
<body>
  <form data-remote="true" action="fail.html">
    <textarea></textarea>
    <input type="submit"/>
  </form>
</body>
</html>

Change History (5)

comment:1 Changed 9 years ago by jitter

I can't reproduce this with jQuery 1.4.3 and IE 6

test case

comment:2 Changed 9 years ago by Rick Waldron

Resolution: worksforme
Status: newclosed

Thanks Jitter

comment:3 Changed 9 years ago by dmethvin

Confirming that jitter's test case also works on IE8/Windows7.

comment:4 Changed 9 years ago by paulrpayne

Retested... it appears this only fails when emulating ie7/8 on ie9beta. Which makes jquery code with ie9 difficult.

comment:5 Changed 9 years ago by jitter

AFAIK jQuery doesn't support IE9 yet because of it's beta status

Note: See TracTickets for help on using tickets.