Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7379 closed bug (duplicate)

Hover function on disabled input doesn't work

Reported by: shibo.2kx@… Owned by:
Priority: high Milestone: 1.5
Component: event Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

When using the hover event on a disabled input, no event is raised (beside for opera 10.63). Same goes for bind with mouseover.

$(document).ready(function(){
  $('.hover-this').bind('mouseover', function(){
    $(this).css({border: '1px solid red'});
  });
        
  $('.hover-this').hover(function(){
    $(this).css({border: '1px solid red'});
  }, function(){
    $(this).css({border: '0px'});
  });
});
For these inputs    Both input have 'hover-this' as class


Change History (5)

comment:1 Changed 9 years ago by anonymous

jsFiddle of the above code: http://jsfiddle.net/LRtQY/

comment:2 Changed 9 years ago by jitter

Practically a dupe of #7359. Check that bug report and my/the comments there

comment:3 Changed 9 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:4 Changed 9 years ago by Rick Waldron

Duplicate of #7359.

comment:5 Changed 9 years ago by Rick Waldron

Component: unfiledevent
Priority: undecidedhigh

More evidence to support the discussion of adding workaround support for this issue.

Note: See TracTickets for help on using tickets.