Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7376 closed bug (worksforme)

Setting backgroundColor with .css in 1.4.3

Reported by: michael@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Noticed a Div stopped changing colors when I upgraded jQuery today. This did work prior (with 1.4.2)

Setting $("div").css("backgroundColor", "red") doesn't work if the css for the same element has

div {

background:white;

}

By changing the css manipulator from backgroundColor to background, div background was successfully manipulated.

Change History (4)

comment:1 Changed 9 years ago by jitter

I can't reproduce this. test case.

Please provide a minimal test case which shows your problem on http://www.jsfiddle.net

Version 0, edited 9 years ago by jitter (next)

comment:2 Changed 9 years ago by Rick Waldron

Owner: set to michael@…
Status: newpending

comment:3 Changed 9 years ago by jitter

Owner: michael@… deleted
Status: pendingnew

comment:4 Changed 9 years ago by jitter

Resolution: worksforme
Status: newclosed

No test case was provided. Closing. Feel free to reopen with a reproducible test case.

Note: See TracTickets for help on using tickets.