Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7335 closed bug (worksforme)

JQuery 1.4.3 breaks flexbox rendering in Webkit?

Reported by: [email protected] Owned by: john
Priority: low Milestone:
Component: css Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Please see http://jsfiddle.net/Heerq/7/ using Chrome 7.0.x on Mac or Windows. This also affects Safari on Mac, though it doesn't seem to reproduce as well in jsfiddle.

Selecting jquery 1.4.2 allows the page to render correctly. Selecting jquery 1.4.3 renders incorrectly, and also has some strange animation/rendering bugs that seem to coincide with the hover effect.

Note that there isn't any usage of jquery, it is simply loaded.

If this is a problem with WebKit please let me know and I'll file against it instead.

Change History (5)

comment:1 Changed 11 years ago by Rick Waldron

Component: unfiledcss
Milestone: 1.51.4.5
Priority: undecidedlow
Status: newopen

Confirmed

comment:2 Changed 11 years ago by john

Owner: set to john
Status: openassigned

comment:3 Changed 11 years ago by dmethvin

Milestone: 1.4.51.5

comment:4 Changed 11 years ago by john

Resolution: worksforme
Status: assignedclosed

I just tested with current Chrome and jQuery and it seems to be fine to me.

comment:5 Changed 11 years ago by anonymous

FWIW, this is still broken for me in that referenced jsfiddle using Chrome 10.0.648.205 on Windows, and any of the jquery versions (including older ones now). At some point I discovered a workaround though, as production code no longer exhibits this behaviour.

Note: See TracTickets for help on using tickets.