Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7307 closed bug (duplicate)

Document Mouseenter Swallows Live and Delegate Handlers

Reported by: zachleat Owned by:
Priority: low Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: mouseenter live delegate Cc:
Blocked by: Blocking:

Description

$('div').trigger('mouseover'); fails to execute handlers bound in live/delegate due to $(document).mouseenter(function() {});

I set up a jsfiddle here: http://jsfiddle.net/xjRVz/

This might be related to #6880 or #6514.

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Keywords: mouseenter live delegate added
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

You are indeed correct in saying that #6880 is related to this issue (its actually the same one). I'll be closing your ticket as a duplicate, but we'll continue the discussion about the fix for this issue in that thread instead. Thanks!.

comment:2 Changed 9 years ago by addyosmani

Duplicate of #6880.

Note: See TracTickets for help on using tickets.