Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7295 closed bug (worksforme)

Quoteless attribute selectors on href in Firefox 3.6 fail to select

Reported by: an0nymity@… Owned by:
Priority: low Milestone: 1.5
Component: selector Version: 1.4.3
Keywords: quoteless attribute selectors Cc:
Blocked by: Blocking:

Description

In jQuery 1.4.2, the following worked in Firefox 3.6: a[href=#actions] or a[href=/some/url/]

but in jQuery 1.4.3, quotes have to be placed around the attribute values.

Change History (3)

comment:1 Changed 9 years ago by addyosmani

Component: unfiledselector
Keywords: quoteless attribute selectors added
Priority: undecidedlow
Resolution: worksforme
Status: newclosed

I've tested your first case (a[href=#actions]) here with FF 3.6.x : http://jsfiddle.net/addyosmani/GBwhh/ and it's working fine with 1.4.3. Your second test case is also working fine http://jsfiddle.net/addyosmani/GBwhh/2/. Tested across FireFox and Webkit-based browsers. Please feel free to re-open if you can provide further test cases that reproduce the issue you submitted.

comment:2 Changed 9 years ago by an0nymity

I'm unable to re-open this ticket, but wanted to provide a test case where this does indeed fail in Firefox 3.6. http://jsfiddle.net/GBwhh/12/

It appears it's actually isolated to "live()", as "bind()" works just fine.

comment:3 Changed 9 years ago by Rick Waldron

#7408 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.