Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7277 closed bug (duplicate)

CSS sibling selectors not working

Reported by: anonymous Owned by:
Priority: high Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

Using ~ or + selectors now fails.

See here http://jsbin.com/ucugi3 and toggle jQuery version between latest and 1.4.2

Change History (3)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledselector
Milestone: 1.51.4.4
Priority: undecidedhigh
Status: newopen

Confirmed - This changes the behavior significantly between versions.

Ex. <table><tr><td class="test"></td><td>Hello world</td></tr></table>

$('td.test:eq(0) ~ td').text()

returns Hello world in 1.4.2 returns nothing in 1.4.3

comment:2 Changed 9 years ago by john

Resolution: duplicate
Status: openclosed

comment:3 Changed 9 years ago by john

Duplicate of #7220.

Note: See TracTickets for help on using tickets.