Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7270 closed bug (duplicate)

.find works wrong when searching by value attribute

Reported by: nv@… Owned by:
Priority: blocker Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: find attribute selector value regression Cc:
Blocked by: Blocking:

Description (last modified by SlexAxton)

html:

<form name="f" id="f">
	<input name="f1" type="text" value="" /> <br/>
	<input name="f2" type="text" value="" /> <br/>
	<input name="f3" type="text" value="" /> <br/>
</form>

js:

$('#f').find('input[value=""]').length

always returns 3 (even if all fields are filled)

in 1.4.2. everything is ok

Change History (7)

comment:1 Changed 9 years ago by nv@…

additional:

test case

http://jsfiddle.net/VNN2T/9/

brouser: firefox 3.6.10 (Win)

comment:2 Changed 9 years ago by SlexAxton

Keywords: find attribute selector value added
Milestone: 1.51.4.4
Priority: undecidedhigh
Status: newopen

This can be reproduced in several browsers. I also checked and made sure that this was a regression. It works as expected in 1.4.2

comment:3 Changed 9 years ago by SlexAxton

Description: modified (diff)

comment:4 Changed 9 years ago by SlexAxton

Component: unfiledselector

comment:5 Changed 9 years ago by snover

Keywords: regression added
Priority: highblocker

comment:6 Changed 9 years ago by snover

Resolution: duplicate
Status: openclosed

comment:7 Changed 9 years ago by snover

Duplicate of #7212.

Note: See TracTickets for help on using tickets.