Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7265 closed bug (duplicate)

jquery 1.4.3 obj.css('width') returns false value

Reported by: kricoune@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

I am creating an object with this code line:

var mynewobj = jQuery('#myTemplate').clone();

then I am adding some attr and styles like this:

mynewobj.attr("id", options.name);
mynewobj.css("z-ndex",currentZIndex++);
mynewobj.css("width",(options.dimention.width+10)+"px");
mynewobj.css("height",(options.dimention.height+56)+"px"); 

now if I ask the width of my new object mynewobj like this:

mynewobj.css('width');

the result is "0px". when if I am using JQUERY 1.4.2 it works just fine and returns the correct width.

p.s when I check the style of this object in the DOM by using "firebug" in firefox browser it shows that it has the correct css width attribute.

Change History (2)

comment:1 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by snover

Duplicate of #7225.

Note: See TracTickets for help on using tickets.