Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7257 closed bug (duplicate)

.attr('checked') does not work as expected for application/xhtml+xml documents

Reported by: kieran@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

It is impossible to use .attr('checked') to read and modify checkbox states for documents that have the application/xhtml+xml content type. Instead, it returns "checked" or "undefined" depending on whether the checked="checked" attribute is specified for the tag. A boolean true/false was expected.

If the document is sent as text/html, it works as expected.

I have tested it in both Firefox and Google Chrome with the same result.

Example: http://caffie.net/checkbox/index.xhtml

Change History (3)

comment:1 Changed 8 years ago by anonymous

comment:2 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

The true/false magic for .checked is a DOM1 HTML behavior and not supported in XHTML.

Dup of #4283 where it is discussed ad nauseum.

comment:3 Changed 8 years ago by dmethvin

Duplicate of #4283.

Note: See TracTickets for help on using tickets.