Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7207 closed bug (invalid)

ie6 & ie7 getScript callback fires too early

Reported by: SEO-developer Owned by:
Priority: undecided Milestone: 1.4.4
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

I use getScript() to load remote Google jsapi and then load a local script that requires access to Google jsapi:

$.getScript( remote-jsapi, getLocal());

function getLocal(){$.getScript(local-script)}

In IE6 & IE7, the local script, which calls google.load(), runs too early resulting in error: "google is undefined"

I can prevent "undefined" error by setting a timeout that gives IE6 & 7 time to load jsapi before calling google.load in my local script.

IE8 & FF handle callback correctly.

Change History (1)

comment:1 Changed 9 years ago by snover

Resolution: invalid
Status: newclosed

Thanks for the report, but this is not a bug. You are invoking the function, not passing it as a reference. Please use the jQuery Forum for support requests.

Note: See TracTickets for help on using tickets.