Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7174 closed enhancement (duplicate)

Animate background-position works for left but not top

Reported by: jason_lau@… Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

$('#obj').animate({'background-position': '20% 80%'},1000); Only the left position animates using this method. It jumps directly to the top position then animates to the left position.

Ideally, it would move to top then left or top and left simultaneously.

Change History (4)

comment:2 Changed 9 years ago by snover

Component: unfiledeffects
Milestone: 1.4.3
Priority: undecidedlow
Status: newopen
Type: bugenhancement

jQuery currently only animates single-value properties. You may try the background-position animate plugin.

comment:3 Changed 9 years ago by jitter

Milestone: 1.next
Resolution: duplicate
Status: openclosed
Version: 1.4.21.5

comment:4 Changed 9 years ago by jitter

Duplicate of #7755.

Note: See TracTickets for help on using tickets.