Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7172 closed bug (duplicate)

base url added when cloning anchor tags in IE7

Reported by: steve@… Owned by:
Priority: undecided Milestone: 1.4.3
Component: unfiled Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

I cloned an element which contains an anchor tag with a relative value in the href attribute. In Firefox, this cloned correctly however in IE7 it added the base url creating the anchor tag in the cloned element with an absolute url.

Steve

Change History (3)

comment:1 Changed 8 years ago by anonymous

Also happens in IE6. Example here:
http://jsfiddle.net/malibu/R6RTd/1/

comment:2 Changed 8 years ago by snover

Resolution: duplicate
Status: newclosed

Unfortunately this is a bug in the IE parser that we cannot work around. If you want to set an href of an element in IE<8 that does not end up absolutized, you must use the .attr function.

comment:3 Changed 8 years ago by snover

Duplicate of #7117.

Note: See TracTickets for help on using tickets.