Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#7127 closed bug (worksforme)

clone() does not preserve whitespace nodes in IE8

Reported by: esprehn Owned by:
Priority: low Milestone:
Component: manipulation Version: 1.4.2
Keywords: clone ie8 Cc:
Blocked by: Blocking:

Description

Whitespace nodes are missing from cloned nodes in IE8 which breaks layout of inline elements.

Change History (7)

comment:1 Changed 10 years ago by addyosmani

Priority: undecidedlow

I believe that the normalization of whitespace here was done to combat an issue IE had with cloneNodes where we're instead consolidating text nodes.

Leaving this bug open in case anyone has suggestions regarding a potential fix we haven't looked at yet.

comment:2 Changed 10 years ago by esprehn

This is a pretty big problem. I've had to stop using clone entirely because something like <span>the</span> <span>fish</span> becomes "thefish" after cloning.

comment:3 Changed 10 years ago by snover

Status: newopen

comment:4 Changed 10 years ago by mohanprajapati2006@…

Clone is not working in ie8

comment:5 Changed 10 years ago by snover

Milestone: 1.4.3

Resetting milestone to future.

comment:6 Changed 10 years ago by snover

Resolution: worksforme
Status: openclosed

I’m not able to reproduce this issue. test case

comment:7 Changed 9 years ago by anonymous

Reproduced in 1.5.2 Conditions described by esprehn above

Note: See TracTickets for help on using tickets.