Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7090 closed bug (worksforme)

Select() causes change() to break on text input fields for MSIE 6 and 7

Reported by: rabid_fish Owned by:
Priority: undecided Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

To recreate, follow these steps: 1) bind a change event to a text input 2) call select() to select all the text in the input 3) have the user edit change the field value in some way and leave the field via tab key or some such 4) notice how the change event did not fire

This is not a problem in Firefox, and I can confirm it was not a problem in jquery 1.3.2. Furthermore, it's only the first change event that is affected - if you tab back into the field, make a change, and leave the field, the change event fires succesfully.

Change History (1)

comment:1 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed

Live test case Unable to reproduce issue in any version of IE with jQuery 1.4.2.

Note: See TracTickets for help on using tickets.