Bug Tracker

Ticket #7081 (closed bug: wontfix)

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#7081 closed bug (wontfix)

whitespace-only selectors throw "Syntax error, unrecognized expression"

Reported by: Tomalak Owned by:
Priority: low Milestone: 1.4.3
Component: selector Version: 1.4.2
Keywords: whitespace expression syntax Cc:
Blocked by: Blocking:


$(" ") throws a syntax error. $("") does not.

The former case can happen when evaluating a HTML Ajax response, for example. When the the response data is passed to jQuery for evaluation it could happens to be a whitespace only string.

Trimming the string before passing it to jQuery fixes this. But realistically, the two variants should yield the same result - an empty jQuery object.

Change History

comment:1 Changed 5 years ago by john

comment:1 Changed 5 years ago by john

  • Milestone changed from 1.4.2 to 1.4.3
  • Resolution set to wontfix
  • Status changed from new to closed

Why should it be the same result? The first is an expression (albeit an invalid one) the second is no expression at all. I suspect that you may just want to trim the result in your application.

Note: See TracTickets for help on using tickets.