Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7069 closed bug (worksforme)

serialize and serializeArray bug

Reported by: tonylucas Owned by:
Priority: low Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

This appears not to support HTML5 input types like tel and number. This is crucial in mobile web development and shouldn't be too difficult to fix.

The fields do not get posted at all, I am currently working around this by making my own serialize function.

Kind Regards,

Tony

Change History (1)

comment:1 Changed 9 years ago by snover

Priority: highlow
Resolution: worksforme
Status: newclosed

jQuery does not pick which elements to serialize, the browser does that. I am not able to reproduce this issue in any browser from the description you have provided.

Test case

If you would like, please provide a test case demonstrating this issue and information on which browser specifically is not working.

Note: See TracTickets for help on using tickets.