Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#7058 closed bug (wontfix)

.css('borderTopWidth')

Reported by: amoschen Owned by: dmethvin
Priority: low Milestone: 1.next
Component: css Version: 1.4.2
Keywords: borderWidth Cc:
Blocked by: Blocking:

Description

When using .css('borderTopWidth'), jquery doesn't take the situation into consideration that when the border-width has not been set in css file, ie's default value is 'medium' while other browsers are '0px'. We'd better unify the return value to '0px' to avoid compatibility issues.

Change History (10)

comment:1 Changed 9 years ago by dmethvin

Priority: undecided

Border dimensions only have meaning if border-style is *not* "none":

http://www.w3.org/TR/CSS2/box.html#border-style-properties

If the browser supports getComputedStyle (basically, everyone but IE) then it takes this into account automatically. Since curCSS is now defined separately for the IE case, a workaround could be applied there.

comment:2 Changed 9 years ago by snover

Milestone: 1.4.31.next
Priority: undecidedlow
Status: newopen

comment:3 Changed 9 years ago by snover

Milestone: 1.4.41.4.5

Retargeting due to severity of regressions in 1.4.3.

comment:4 Changed 9 years ago by dmethvin

Owner: set to dmethvin
Status: openassigned

comment:6 Changed 9 years ago by dmethvin

Milestone: 1.4.51.5

comment:7 Changed 8 years ago by dmethvin

Milestone: 1.7

I have a patch for this but am not convinced it's worth the bytes. Comment here and vote up the ticket if you think otherwise and we'll review for 1.7.

comment:8 Changed 8 years ago by john

Milestone: 1.71.next
Resolution: wontfix
Status: assignedclosed

Yeah, sounds like we're just going to punt on this.

comment:9 Changed 8 years ago by dmethvin

#9484 is a duplicate of this ticket.

comment:10 Changed 8 years ago by dmethvin

#10855 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.