Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7051 closed bug (worksforme)

get failure with non standard domain/port

Reported by: osmixtacebi Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: Cc: paul
Blocked by: Blocking:

Description (last modified by snover)

$.get('http://192.168.1.212:2222/some/folder/'), null, function(data){_code_}); doing a remote GET (as above) in the latest jQuery causes an error when the server has no name, just IP address, and non standard port (http://192.168.1.212:2222/)

It may not be the IP address, but the port.

It may also be present in older versions, I have not checked. (1.4.2 dev version was used)

If this can not be reproduced, I can supply other information as required.

The same code used on a "regular url" failed when moved to a url as described above. jquery was tried as remote server include, and as local server include, with the same result.

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Component: unfiledajax

comment:2 Changed 9 years ago by snover

Description: modified (diff)
Priority: undecided
Resolution: worksforme
Status: newclosed

I run jQuery on nonstandard ports constantly during testing, so that is definitely not the issue here. I ran the jQuery testsuite from git/master and experienced no AJAX failures. Also, what is up with the spammy description? jQuery’s bug tracker is not for your own personal SEO.

Note: See TracTickets for help on using tickets.