Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7015 closed bug (invalid)

AJAX not working when used from a custom plugin in Internet Explorer (jquery 1.4.x)

Reported by: h_guillaume Owned by:
Priority: Milestone: 1.4
Component: ajax Version: 1.4.2
Keywords: ajax ie 1.4.x not working Cc:
Blocked by: Blocking:

Description

When I use the AJAX directly in a web page, it works.

When I use AJAX inside a plugin, it gives me an error.

Note: When I use the following ajaxSettings from the code of the section (jquery 1.3.x) it worked.

ajaxSettings: {

url: location.href, global: true, type: "GET", contentType: "application/x-www-form-urlencoded", processData: true, async: true, /* timeout: 0, data: null, username: null, password: null, */ Create the request object; Microsoft failed to properly implement the XMLHttpRequest in IE7, so we use the ActiveXObject when it is available This function can be overriden by calling jQuery.ajaxSetup xhr:function(){

return window.ActiveXObject ? new ActiveXObject("Microsoft.XMLHTTP") : new XMLHttpRequest();

}, accepts: {

xml: "application/xml, text/xml", html: "text/html", script: "text/javascript, application/javascript", json: "application/json, text/javascript", text: "text/plain", _default: "*/*"

}

},

Change History (2)

comment:1 Changed 8 years ago by h_guillaume

Bug was not because of plugin. I opened a new bug related to the exact problem with the details and files to reproduce bug. Bug #7048.

comment:2 Changed 8 years ago by snover

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.