Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7011 closed bug (fixed)

noConflict is broken by Commit #8effe3a7dee91c833cc1774646da9d743600c64c

Reported by: Rick Waldron Owned by:
Priority: Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

Check out:

http://github.com/jquery/jquery/commit/8effe3a7dee91c833cc1774646da9d743600c64c#diff-2

This commit breaks jQuery.noConflict(true) - jQuery/_jQuery is actually undefined when it is called.

Removing the closure fixes the problem

Also - the unit tests are not passing because of this.

Change History (4)

comment:2 Changed 9 years ago by Rick Waldron

Additionally, here is the test case that shows the breakage:

http://jsbin.com/ujije4/9

comment:3 Changed 9 years ago by cowboy

The problem is that because the var jQuery declaration in core.js happens inside a core-specific closure, when any non-core jQuery function tries to resolve jQuery it must go all the way up the scope chain to window to get it, which explodes all over the place when noConflict(true) is used.

This is a pretty major issue.

comment:4 Changed 9 years ago by john

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.