Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7000 closed bug (duplicate)

The "live change" event of the "select" element is called twice

Reported by: marat Owned by:
Priority: undecided Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: live, select, onchange Cc:
Blocked by: Blocking:

Description

If we have some "select" elements which are used the "live" binding model:

$("select").live("change", fn);

and some "select" elements which are used the "inline" binding model:

<select onchange="fn();">...</select>

and if we call the "change" event then this event will be called twice.

If we re-write the existing "inline" binding model to the the following binding model:

$("select").change(fn);

then this case will not reproduced.

Please, see the attached example.

Note: Reproduced only in IE 8 (IE 7 compatibility mode)

Attachments (1)

jquery_live_bug.htm (1.0 KB) - added by marat 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by marat

Attachment: jquery_live_bug.htm added

comment:1 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #6593.

Note: See TracTickets for help on using tickets.