Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6966 closed enhancement (duplicate)

.andSelf(selector)

Reported by: dmethvin Owned by:
Priority: low Milestone:
Component: traversing Version: 1.4.2
Keywords: needsreview Cc:
Blocked by: Blocking:

Description

Comment on api.jquery.com from Nick Craver:

What are the chances of giving this the ability to take a selector? When any descendant or current elements that match the current selector, there's not a quick way to do this, currently it's .find(selector).andSelf().filter(selector) or some combination, would be nice if .andSelf() was able to take a selector already, doing the filter internally.

Change History (4)

comment:1 Changed 9 years ago by snover

Keywords: needsreview added
Priority: low

Smells like bikeshed/feature creep. Marking for review.

comment:2 Changed 9 years ago by snover

Milestone: 1.4.3

Resetting milestone to future.

comment:3 Changed 8 years ago by addyosmani

Resolution: duplicate
Status: newclosed

comment:4 Changed 8 years ago by addyosmani

Duplicate of #4446.

Note: See TracTickets for help on using tickets.