Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6954 closed bug (duplicate)

The selector a[href=""] selects anchors without href attributes in IE, but not Chrome/Firefox

Reported by: zacherates Owned by:
Priority: undecided Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

The title says it all:

$("a[href=]) selects both <a href=""> and <a> nodes in IE, but not on FireFox or Chrome. I reproduced this with the nightly as of August 26th, 2010.

Attachments (2)

empty-nightly.png (46.2 KB) - added by zacherates 9 years ago.
Screenshot demonstrating the behavior
empty.html (582 bytes) - added by zacherates 9 years ago.
I forgot to take out an alert, doh!

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by zacherates

Attachment: empty-nightly.png added

Screenshot demonstrating the behavior

comment:1 Changed 9 years ago by zacherates

I've attached a screenshot of the behavior as well as an html page that reproduces the behavior.

Changed 9 years ago by zacherates

Attachment: empty.html added

I forgot to take out an alert, doh!

comment:2 Changed 9 years ago by dmethvin

Component: unfiledselector

comment:3 Changed 9 years ago by snover

need: ReviewPatch
Priority: undecided

I am able to reproduce this issue in IE7 only. IE8 works properly. Live test case

comment:4 Changed 9 years ago by snover

Blocked by: 7128 added
Milestone: 1.4.31.next
Status: newopen
Version: 1.4.21.4.3

comment:5 Changed 9 years ago by snover

Blocked by: 7128 removed
Resolution: duplicate
Status: openclosed

comment:6 Changed 9 years ago by snover

Duplicate of #7128.

Note: See TracTickets for help on using tickets.