Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6948 closed bug (duplicate)

div[name='divName'] in IE7 does not select

Reported by: hasselback Owned by:
Priority: undecided Milestone: 1.4.3
Component: selector Version: 1.4.2
Keywords: div, name attribute Cc:
Blocked by: Blocking:

Description

Div elements in conjunction with selection by attribute name do not select.

Results for IE 7 only (tested in IE tester and IE8 compatibility mode)

Attachments (1)

jq_div_name.html (1.1 KB) - added by hasselback 9 years ago.
Short HTML example of errors

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by hasselback

Attachment: jq_div_name.html added

Short HTML example of errors

comment:1 Changed 9 years ago by addyosmani

need: ReviewPatch
Priority: undecided

Confirmed IE7 behaviour submitted is a bug. Additional testing in IE8 and IE9 shows the bug appears to be limited to 7.0.

The test case works fine in FireFox 3.6.10 and Chrome 6.04.

comment:2 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

live test case

name is not a valid attribute on <div> elements, so unreliable behaviour can be expected. Don’t do this!

comment:3 Changed 9 years ago by snover

Duplicate of #7128.

Note: See TracTickets for help on using tickets.