Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#6939 closed bug (duplicate)

find() works incorrectly with attribute selectors

Reported by: checat Owned by:
Priority: undecided Milestone: 1.4.3
Component: selector Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery('.item img[src=nav]')
and
jQuery('.item').find('img[src
=nav]')
give different results.

"find" looks into "img.src" and matches with full URL, while "jQuery" looks into original attribute value.

#5810 may be related to it

Attachments (1)

jQuery-bug-find.html (1.5 KB) - added by checat 8 years ago.
Bug demonstration

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by checat

Attachment: jQuery-bug-find.html added

Bug demonstration

comment:1 Changed 8 years ago by checat

In jQuery-bug-find.html first 8 lines of report show correct use of "img src" original attribute (I assume, via getAttribute('src')) which contains relative URL, but last 3 lines show access to full URL (I assume, via .src property).

comment:2 Changed 8 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by snover

Duplicate of #7128.

Note: See TracTickets for help on using tickets.