Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6925 closed bug (fixed)

.empty() sometimes will throw an "'events' is null or not an object" error in Internet Explorer

Reported by: vinay Owned by:
Priority: undecided Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

The bug can be recreated by going to http://lispclub.com/~vinay/jquery_ie_events_bug.html and clicking 'Offering type' in Internet Explorer, and then the "next" button on the overlay window that pops up (please forgive the styling and lack of problem reduction, in a big hurry.) This is an issue at least on IE 8, but the problem does not show up in chrome or firefox.

The error dialog states (on non-minified jquery 1.4.2): "A Runtime Error has occured. Do you wish to Debug? Line: 4519 Error: 'events' is null or not an object"

Looking at the stack trace, this is caused by the .empty() on line 72 of jquery_ie_events_bug.html.

I was able to fix this bug by changing line 4519 of non-minified jquery 1.4.2 from if ( data.events != null) { to if ( data && data.events != null) {

This fix was just a hack and I don't know the root cause.

Hope this helps... looks like this could be causing problems for others as well (http://forum.jquery.com/topic/load-using-tabsselect-causes-events-is-null-error-in-ie-urgent-help-needed)

Change History (2)

comment:1 Changed 9 years ago by vinay

Any word on this problem?

comment:2 Changed 9 years ago by dmethvin

Priority: undecided
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.