Bug Tracker

Opened 9 years ago

Closed 9 years ago

#6869 closed bug (duplicate)

.one() method throws error with plain Javascript object

Reported by: Christopher Owned by:
Priority: Milestone: 1.4.2
Component: event Version: 1.4.2
Keywords: one bind trigger event Cc:
Blocked by: Blocking:

Description

With jQuery JavaScript Library v1.4.2 of Sat Feb 13 22:33:48 2010 -0500 on http://code.jquery.com/jquery-1.4.2.js

I bind a event with ".one()" methode (http://api.jquery.com/one/). And when trigger send an event. The methode handler is never called.

Attachments (1)

testjs.html (736 bytes) - added by Christopher 9 years ago.
code

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Christopher

Attachment: testjs.html added

code

comment:1 Changed 9 years ago by dmethvin

Thank you for the test case, I was able to reproduce the problem. The issue is that .one() is trying to unbind the event on the plain Javascript object. That ends up as a call to object.removeEventListener which doesn't exist.

We don't run into this problem with adding the event because jQuery.event.add checks the element itself to see if it supports addEventListener/attachEvent and since it supports neither it does nothing there.

comment:2 Changed 9 years ago by dmethvin

Summary: .one() methode don't function any more.one() method throws error with plain Javascript object

comment:3 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is fixed in the nightlies, dup of #6184.

Note: See TracTickets for help on using tickets.