Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6858 closed bug (worksforme)

IE6 and IE7 textarea val() does not work

Reported by: olvi Owned by:
Priority: undecided Milestone: 1.4.3
Component: attributes Version: 1.4.2
Keywords: textarea val ie Cc:
Blocked by: Blocking:

Description

Cant update textarea value with val(). In IE8 and all other browsers works fine.

Attachments (1)

test.html (353 bytes) - added by olvi 9 years ago.
Sample script

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by olvi

Attachment: test.html added

Sample script

comment:1 in reply to:  description Changed 9 years ago by olvi

I'am using Spoon Browser Sandbox if it has something to do with it...

comment:2 Changed 9 years ago by jitter

Probably invalid bug-report. Your test-case (as you yourself mentioned) works in every major browser so if this Spoon Browser Sandbox messes with the default behavior of the sandboxed browsers you should file a reproducible bug report to the Spoon team.

I installed the Spoon Browser Sandbox plugin and tried your test with FF4b2, IE8 and Opera10 but it worked in all those sandboxed browsers.

Maybe retest again and add which browser exactly you use to launch the Spoon Sandbox and which browser this test fails in when sandboxed.

comment:3 Changed 9 years ago by jitter

Missed that you specified IE6/7 in the bug title as not working. I went back and tried IE6/7 via Spoon Browser Sandbox on your testcase too. They both displayed a textarea with the text "It works!" so I can't reproduce your bug.

Maybe the Spoon plugin was updated since or something else is the cause. But it is neither jQuery nor IE6/7

comment:4 Changed 9 years ago by addyosmani

Priority: undecided
Resolution: worksforme
Status: newclosed

Both jitter and I have been able to update the value of textarea across all major recent versions of IE (6,7,8 and I just tested 9) through val() without any problems. I think that this is a case of the Spoon Browser SandBox being responsible for the bug (or an older version of it).

Flagging as worksforme.

comment:5 Changed 8 years ago by anonymous

textarea.val does not work in IE8 and below ONLY when that value was generated automatically, (php session value, etc)

Note: See TracTickets for help on using tickets.