Bug Tracker

Opened 9 years ago

Closed 9 years ago

#6855 closed bug (invalid)

IE in Win7 problem with S.ajax

Reported by: Helge Vadim Owned by:
Priority: Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Ajax IE Cc:
Blocked by: Blocking:

Description

When IE load the site first time after the clicking on element must script to work, but appears the notification window "The object does not support this property or a method. Code 0. String 123, symbol 183 in jquery-1.4.2.min.js" If I made page reloading - script start to work normally. So, how I can solve this trouble?

Simple code: <li onclick="ask_kat ('FHCTF', 'kuhen_fltr')

In head I connect: <SCRIPT language="javascript" src="./scr/jquery-1.4.2.min.js" type="text/javascript"></script>

Body of the function "ask_kat": function ask_kat (A, P) {

$.ajax({ type: "POST", url: "php/fragen.php",

cash: true,

data: {produkt:A, table:P}, success: function(html){

$("#Center").html(html);

}

}); }

Body of the fragen.php: php $kat.=$_POSTprodukt?; $tbl.=$_POSTtable?;

print $kat."<br>"; print $tbl;

Attachments (2)

fragen.php (158 bytes) - added by Helge Vadim 9 years ago.
PHP file
Mistake.jpg (105.6 KB) - added by Helge Vadim 9 years ago.
IE message

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Helge Vadim

Attachment: fragen.php added

PHP file

Changed 9 years ago by Helge Vadim

Attachment: Mistake.jpg added

IE message

comment:1 Changed 9 years ago by Helge Vadim

P.S. I told about IE8 in Windows 7.

comment:2 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

This looks like a typo:

cash: true, 

should be

cache: true,

If there is still a problem, ask for help on the forum so others can help to narrow down the cause.

Note: See TracTickets for help on using tickets.