Skip to main content

Bug Tracker

Side navigation

#6829 closed bug (invalid)

Opened July 27, 2010 03:39AM UTC

Closed October 03, 2010 03:54AM UTC

get failure with non standard domain/port

Reported by: paulwratt Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: get Cc:
Blocked by: Blocking:

$.get(''), null, function(data){_code_});

doing a remote GET (as above) in the latest jQuery causes an error when the server has no name, just IP address, and non standard port (

It may not be the IP address, but the port.

It may also be present in older versions, I have not checked. (1.4.2 dev version was used)

If this can not be reproduced, I can supply other information as required.

The same code used on a "regular url" failed when moved to a url as described above. jquery was tried as remote server include, and as local server include, with the same result.


Attachments (0)
Change History (1)

Changed October 03, 2010 03:54AM UTC by addyosmani comment:1

priority: → undecided
resolution: → invalid
status: newclosed

The reason for this failing is that a different port on the same server or website still violates the XHR Cross domain policy. The only way it could work is by either using JSONP (does not support POST requests) or a proxy webservice on the same server.

You'll unfortunately need to use one of the above suggestions (or alternatively a qualified domain name that doesn't use a non-standard port).