Bug Tracker

Opened 9 years ago

Closed 9 years ago

#6791 closed bug (duplicate)

Animate on IMG elems incorrectly sets style.display to "block"

Reported by: shaungrady Owned by:
Priority: undecided Milestone: 1.4.3
Component: effects Version: 1.4.2
Keywords: animate update img display Cc:
Blocked by: Blocking:

Description

When running an animation on an IMG elem, the fx update function sets the style.display to "block". IMG elems can have both dimensions set while in their native display-type of "inline".

Patch of line 5738

From: this.elem.style.display = "block";

To: this.elem.style.display = this.elem.tagName === "IMG" ? "inline" : "block";

Change History (1)

comment:1 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #2185.

Note: See TracTickets for help on using tickets.