Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6728 closed bug (duplicate)

jQuery 1.4.2 regression in Internet Explorer XMLHttp ?

Reported by: carpii Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: ie, xmlhttp, exception Cc:
Blocked by: Blocking:

Description

This is an odd problem, but can be reproduced reliably (and has been by many of my users)

I cant describe it very well, so its best I supply an example file.

Summary


Clicking one of the buttons does an ajax post. All works fine in firefox.

In internet explorer 7 and 8, and jquery 1.4.2, the buttons will fail with a jQuery exception.

The exception occurs when it tries to create an XMLHTTPObject, and the error is 'object does not support this property or method)

Usually if you force a reload of the page, by holding SHIFT+refresh, oddly, the buttons will then start working.

Then go to the browser address bar, and hit enter so its basically using a cached copy, and the buttons will fail again.

The reload issue is not actually cache related that I can tell. Disabling the browser cache completely produces the same results (?!).

Reverting to jquery 1.2.6 resolves the problem (although there might be later versions which work too)

Attachments (1)

view.html (2.3 KB) - added by carpii 9 years ago.
HTML file demonstrating XMLHttp exception problem

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by carpii

Attachment: view.html added

HTML file demonstrating XMLHttp exception problem

comment:1 Changed 9 years ago by carpii

Reduced the test case even further, so its just a link, and not a graphical button image. Problem description is summarised in attached HTML

comment:2 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of Bug #6298.

Note: See TracTickets for help on using tickets.