Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6634 closed bug (duplicate)

form attributes somtimes become readonly and then .attr() doesn't work anymore

Reported by: AL13N Owned by:
Priority: Milestone: 1.4.3
Component: attributes Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

i thought i found a bug in FF: https://bugzilla.mozilla.org/show_bug.cgi?id=568779

but if you read the response i got from the mozilla team, you see that it's a "feature".

how does it work exactly?

if you have a form, and you have a form element in it, with name or id having one of the attribute names of that form (name, action, ...), the form attribute in question becomes readonly with the generic accessors (the property), however, the setAttribute() function works as a workaround.

in my code i had to do: .attr(k, v) IF .attr(k) != v .get(0).setAttribute(k, v)

my proposal is to fix this workaround inside the .attr() function. so that this "feature", will not be problematic with all those users. it lost huge amounts of time due to this "feature"

Change History (1)

comment:1 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #3113.

Note: See TracTickets for help on using tickets.