Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6612 closed feature (duplicate)

Support additional request types for caldav

Reported by: haraldk Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: caldav REPORT Cc:
Blocked by: Blocking:

Description

Caldav uses, for example, REPORT instead of PUT. In line 5252 of jquery-1.4.2.js we have

xhr.send( type === "POST"
type === "PUT" type === "DELETE" ? s.data : null )

It would be cool if this were configurable and would rather read something like

xhr.send( s.sendData[type] ? s.data : null )

where s.sendData is a map from request types to true or false.

Change History (2)

comment:1 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by snover

Duplicate of #6462.

Note: See TracTickets for help on using tickets.