Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6568 closed bug (duplicate)

$('#id > some_tag:first') does not work in Chrome

Reported by: mmmikeyyy Owned by:
Priority: Milestone: 1.4.3
Component: selector Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

in Chrome, the above syntax is not working.

Had to convert all occurrences to

$('#id').children('some_tag:first')

Syntax in title returns 0-length set in Chrome. Works in IE, Safari and FF.

If :first is replaced with :eq(0), it works.

Note: ":last" works fine in all browsers.

Question: when a bug is fixed, how can we get the fix without having to wait months for the next version??

Change History (2)

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #6519, which says this is a webkit bug. Is this a shipping version of Chrome, or a nightly?

comment:2 Changed 10 years ago by mmmikeyyy

it's this version of Chrome: 6.0.401.1 dev

(shipping version)

Note: See TracTickets for help on using tickets.