Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6546 closed feature (worksforme)

1.3.2 .text() function does not return result for textarea in Chrome 5, Firefox 3.6

Reported by: ericbojo Owned by:
Priority: Milestone: 1.4
Component: attributes Version: 1.3.2
Keywords: text, textarea, value, Cc: ericbojo@…
Blocked by: Blocking:

Description

Pretty simple bug. $('#textarea').text(); returns the inputted textareas text in IE8, but returns nothing in FF3.6 and Chrome 5 (beta). .val(); does what is expected, not sure if this is a bug or by design. Only tested with jQuery 1.3.2

Recommend a test case be made for this.

Attachments (1)

test-6546.html (409 bytes) - added by dmethvin 9 years ago.
test case

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by dmethvin

Type: bugfeature

The correct way to get the text inside a textarea is to use its value attribute, which .val() does. I have changed this to a feature request but it may be closed worksforme.

comment:2 Changed 10 years ago by tomasbarao

var variable = $("textarea#mytext").val(); doesn't work too! The val() method returns an empty string.

Changed 9 years ago by dmethvin

Attachment: test-6546.html added

test case

comment:3 Changed 9 years ago by dmethvin

Resolution: worksforme
Status: newclosed

Works fine.

Note: See TracTickets for help on using tickets.