Bug Tracker

Opened 11 years ago

Closed 11 years ago

#6541 closed bug (invalid)

Weird behaviour of click handler in WebKit-based browsers

Reported by: Sayan.Chaliha Owned by:
Priority: Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

Here's some sample code:

Click handler for checkbox

$('input:checkbox').click(function(evt) {

evt.stopImmediatePropagation();

$(window).trigger('click');

return true;

});

Click handler for container of checkbox

$('#container').click(function() {

Do something which should not be done when clicking on

the checkbox

});

$(window).click(function() {

Check if a drop-down menu is open somewhere, and close it

$('#drop-down').addClass('hidden');

});

The problem is that in WebKit-based browsers (Chrome and Safari to be exact), and also in IE7, clicking on the checkbox doesn't cause it get checked! On Firefox, Opera and IE8 it works absolutely fine!!

Change History (1)

comment:1 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

Just to be sure we see what you're seeing, can you reopen and attach a complete test case?

Note: See TracTickets for help on using tickets.