Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6515 closed bug (worksforme)

API docs steal arrow keys [documentation bug]

Reported by: whatcould Owned by:
Priority: undecided Milestone: 1.4.3
Component: misc Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

API docs should not hijack arrow keys for custom behavior.

To reproduce: Attempt to use arrow keys to scroll page, like every other website

Expected result: Page scrolls

Current result: Page jumps abruptly to the "focused" method

Maybe you could use j/k for up/down? Hijacking arrow keys is a usability nightmare.

Change History (1)

comment:1 Changed 9 years ago by dmethvin

Priority: undecided
Resolution: worksforme
Status: newclosed

I can see your concern, but the way it's set up now actually makes the keyboard more usable since you can tab/arrow through the entries quickly and hit enter to go to the entry in focus. If you'd like to start a discussion on the forum to propose a better way, feel free but I'll close this since it's not really a bug.

Note: See TracTickets for help on using tickets.