Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6504 closed bug (invalid)

$(element).children("xxxxx") is sometimes very slow or infinite loops

Reported by: jason.sadler Owned by:
Priority: Milestone: 1.4.3
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Under some very specific circumstances (which I haven't been able to completely figure out), the children() call can be extremely slow (on the order of 10 seconds in IE8) or appears to loop infinitely (on FF3.6)

This only happens under certain selectors, and the failure appears to occur in the chunker.exec call on the selector.

An example of such a selector is: var selector = "input[name=f_5303][value*=\"Test%20%22%20and%20'%20pipe%20%7C%20pipe!\"]"

Unfortunately I've been unable to find a general case to say "it fails for apostrophes" or something, although the problem seems to be somehow related to the apostrophe (cleartext) and/or pipe (encoded as %7C) in the above selector.

Change History (1)

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Can you (or someone else encountering the problem) reopen this ticket with a test case? It's not possible to reproduce/fix the problem with the information provided.

Note: See TracTickets for help on using tickets.