Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6480 closed bug (duplicate)

Create XHR object sometimes fails on IE7/8

Reported by: Mac_J Owned by:
Priority: Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: ajax XHR XMLHTTP XMLHttpRequest Cc:
Blocked by: Blocking:

Description

In some case, it dosn't work when you open web page at first. Must refresh the page.

I modified code at line 4952. It's work.

xhr: function() {

try {

return new ActiveXObject("Msxml2.XMLHTTP");

} catch (e) {

try {

return new ActiveXObject("Microsoft.XMLHTTP");

} catch (e2) {}

} if (!xmlHttp && typeof XMLHttpRequest != 'undefined')

return new XMLHttpRequest();

},

Change History (4)

comment:1 Changed 10 years ago by Mac_J

It appeared in IE8 that I just test.

comment:2 Changed 10 years ago by Bradley

Keywords: ajax added
Milestone: 1.4.21.4.3
Summary: JQUERY1.4.2 Create XHR Object BUGjQuery 1.4.2 create XHR object sometimes fails on IE7/8

Test case available at dup #6586

comment:3 Changed 10 years ago by Bradley

Summary: jQuery 1.4.2 create XHR object sometimes fails on IE7/8Create XHR object sometimes fails on IE7/8

comment:4 Changed 10 years ago by Bradley

Resolution: duplicate
Status: newclosed

Duplicate of #6298, has test case.

Note: See TracTickets for help on using tickets.