Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#6431 closed bug (invalid)

Error when using jQuery 1.4.1, Prototype 1.6.1, jqPlot, and IE8

Reported by: johnlicheng Owned by:
Priority: Milestone: 1.4.1
Component: unfiled Version: 1.4.1
Keywords: noConflict prototype Cc:
Blocked by: Blocking:

Description

Steps to reproduce:

Unzip attached file and open example1/index.html. Go to the 2nd test in IE 8 and you will see an error.

Expected result:

No errors

Actual result:

Error message "TypeError: 'document.documentElement' is null or not an object"

Description:

I've included a test case where IE throws a TypeError: document.documentElement is null... when using jQuery 1.4.1 with Prototype 1.6.1 and jqPlot, but the error does not occur when jQuery 1.3.2 is used (or if Prototype 1.6 is used).

This tells me that something in jQuery 1.4.1 and Prototype 1.6.1 are conflicting with each other.

Attachments (1)

example1.zip (197.6 KB) - added by johnlicheng 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by johnlicheng

Attachment: example1.zip added

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Please reduce to a simpler test case. Since prototypejs is involved it most likely is caused by pollution of the global name space or Object prototype.

Note: See TracTickets for help on using tickets.